Subject: uruk: please make the build reproducible

From: Chris Lamb <[email-masked]>
Date: Tue, 03 Feb 2015 16:41:44 +0000

Source: uruk
Version: 20140627-1
Severity: wishlist
Tags: patch
User: [email-masked]
Usertags: timestamps
X-Debbugs-Cc: [email-masked]

Hi,

While working on the "reproducible builds" effort [1], we have noticed
that uruk could not be built reproducibly.

The attached patch removes timestamps from the build system. Once
applied, uruk can be built reproducibly in our current experimental
framework.

 [1]: https://wiki.debian.org/ReproducibleBuilds

Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      [email-masked] / chris-lamb.co.uk
       `-
diff -urNad uruk.orig/uruk-20140627/debian/rules uruk/uruk-20140627/debian/rules
--- uruk.orig/uruk-20140627/debian/rules	2015-02-03 16:39:59.872172541 +0000
+++ uruk/uruk-20140627/debian/rules	2015-02-03 16:40:26.965354892 +0000
@@ -70,8 +70,8 @@
 	cp -a debian/README $(docdir)/README.Debian
 	cp -a debian/TODO $(docdir)/TODO.Debian
 	cp -a ChangeLog $(docdir)/changelog
-	cd $(docdir) && gzip -9 changelog changelog.Debian ChangeLog.2003 NEWS.Debian
-	gzip -r9 debian/$(package)/usr/share/man
+	cd $(docdir) && gzip -9n changelog changelog.Debian ChangeLog.2003 NEWS.Debian
+	gzip -r9n debian/$(package)/usr/share/man
 	mkdir debian/$(package)/DEBIAN
 #       # generate md5sums.  pathnames should not have leading /.
 #       # conffiles should be excluded.  for now, assume conffiles are precisely

---

From: Joost van Baal-Ilić <[email-masked]>
Date: Tue, 3 Feb 2015 18:06:35 +0100

Hi Chris,

Thanks, will get to it.  Will be fixed in next upload.  (In the mean time, feel
free to NMU; I like reproducable builds.)

Bye,

Joost